読者です 読者をやめる 読者になる 読者になる

OS X で NASM を使っている人は、バージョン 2.11.08 を回避してください

こちらのバグ、Bug 3392306 - Issue with relative addressing and data section ( http://bugzilla.nasm.us/show_bug.cgi?id=3392306 )のために、OS X で NASM 2.11.08 はまともに使えません。

Homebrew を使っている場合は nasm21106 で 2.11.06 が入りますのでそちらを使いましょう。あるいは git から最新版の NASM も使えるかもしれません(試してない)。